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[bookmark: _Toc70496282]Make your data into a table
2. Click on the Table command button 

[image: ]1. Click on the Insert tab 

Alternative shortcut: Ctrl + T
[image: ]3.  A window will open. Confirm the cells to be included in the table and that the data has headers

[bookmark: _Toc33454288][bookmark: _Toc70496283]Name the table
It is good practice to name the table as it makes life much easier later when working with formulas. Naming the formula is basically giving your data set a name which will enable you to recognise which data set you need to be working with.
[image: ]2. Rename the table. For example, “BookingData”
1. Click on the table & select the Design tab

[bookmark: _Toc70496284][bookmark: _Toc33454318]Get & Transform data
Power Query will always create the attribute-value pair by using two columns: 
Attribute The name of the column headings that were unpivoted. 
Value The values that were underneath each of the unpivoted column headings.
[bookmark: _Toc70496285]Use a Power Query to Unpivot data (version 1 for tabular data)
Before starting, put the data you want to transform into a Table (see section above for instructions).
[image: ]1. Click on From Table/Range to create a query & open the Power Query Editor
1. In the Power Query Editor, select the Transform tab 
2. Select the columns you want to unpivot (hold down the shift key to select multiple columns)
3. Click on Unpivot Columns



4. Highlight the column, right-mouse click and select Remove
Attribute column = the possible values or column headings. 
This column can be deleted as we do not need it.

























5. Return to the Home tab 
6. Click on Close & Load to save the query and return the results to a new worksheet










The results will appear as a table in a new worksheet and you are now ready to use a Pivot table to analyse the data.
[bookmark: _Toc70496286]Use a Power Query to Unpivot data (version 2 for delimited data)
[bookmark: _Toc70496287]What is a delimiter in Excel?
A delimiter is one or more characters that separate text strings. Common delimiters are commas (,), semicolon (;), quotes ( ", ' ), braces ( {}), pipes (|), or slashes ( / ). When a program stores sequential or tabular data, it delimits or separates each item of data with a predefined character.2. Click on From Table/Range to create a query & open the Power Query Editor
1. Click on the Data tab

3.Click on the Transform tab
4.Highlight the column you want to unpivot
5.Select By Delimiter from the Split Column dropdown menu

6.Select the type of delimiter
7.Click on OK


8.Highlight the columns to unpivot
9. In the Transform tab, click on Unpivot columns


















[image: ]10. Select the Attributes column, right click on the right mouse button & Remove 


12. In the Home tab, click on Close and Load to save the query and create a worksheet for the results
11. Use the filter on the Value field to remove blanks from the query


[bookmark: _Toc70496288]Pivot Tables
[bookmark: _Toc33454319][bookmark: _Toc70496289]Creating a pivot table
1. Click on the Insert tab 
2. Click on Pivot Table




2. Select the table you want to base the pivot table on. Here you can see the table name “participants”. Using a table ensures you have a dynamic data source for your pivot table











3. Select New Worksheet 























This will automatically update the table as below, now displaying dates across as columns






5. The columns from your table appear in the fields





4. An empty pivot table is created






[image: ]6. To create a simple pivot table that shows the number of prisoners attending sessions from each prison drag and drop the Prison field into the Rows box and the Name field into Values








7. The pivot table now displays how many prisoners attended the music sessions from each prison







8. As the name field is text the pivot table assumes you want to Count the number of records in the Name
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[image: ]9. Add complexity to your Pivot table. To show how many of the attendees from each prison already had musical experience, add the field Musical experience to the Columns field









[bookmark: _Toc33454320][bookmark: _Toc70496290]Field values
[image: ]2. Select Show Values As and then % of Grand Total








1.Highlight the fields you want to display as a percentage.










[image: ]4. Use the Decrease decimal place command button to round numbers.








3. Percentages replace the original numbers









[bookmark: _Toc33454321][bookmark: _Toc70496291]Sorting & Filtering a pivot table
Simple sorting and filtering work exactly the same as elsewhere in Excel.
Click next to the row or column heading for sorting and filtering options





















[bookmark: _Toc70496292]Sort by count of values
1. Click on the arrow next to Row labels & select Sort Options








2. Select Count of Row name for a numerical not alphabetical sort








3. The chart always shows the opposite sort order so select Descending to have the largest column show first









[bookmark: _Toc33454322][bookmark: _Toc70496293]Add a Slicer to a pivot table1. Click on Insert Slicer








[image: ]
[bookmark: _Toc33454323][bookmark: _Toc70496294]Formatting a pivot table
Like Tables, Pivot Tables can be formatted. 
1. Click on the pivot table and then on the Design tab







2. Add and remove specific headers or banding for rows & columns







3. Change the format (colours, banding, outline etc)

















[bookmark: _Toc33454324][bookmark: _Toc70496295]Refreshing data in a Pivot table
[image: ]If you make changes to the data set being used to the pivot table, you might need to refresh the chart so that the changes are immediately reflected in the chart.

[bookmark: _Toc33454325][bookmark: _Toc70496296]Recommended Pivot Tables
A short cut to creating pivot tables can be to use the recommended Pivot table function.



[bookmark: _Toc70496297]Changing value field settings
In pivot tables you can select different types of setting for the values portion of your Pivot table. You can:
· Give the value set a custom (display) name
· Specify how you want to summarise values 
· Specify how you want to display values
1. Right mouse click on the Value eg Sum of Client ID and select the option Value Field Settings


















[bookmark: _Toc70496298]Custom value name
Type in the name you would like to use for the value field. 

[bookmark: _Toc70496299]Summarise values by

[image: ]2. Select how you want your field summarised 
1. Select the tab Summarise Values By 

Most common calculations used to summarise data:
	Function 
	Summarizes 

	Sum
	The sum of the values adds all the values in the selected data range. This is the default function for numeric values.

	Count
	The number of values. The Count summary function works the same as the COUNTA worksheet function. Count is the default function for values other than numbers.

	Average
	The average of the values. The average is the mean average of the numbers. To calculate: Excel adds up all the numbers, then divides by how many numbers there are. In other words it is the sum divided by the count.

	Max
	The largest value.

	Min
	The smallest value.

	Product
	The product of the values. The product is the result of multiplying the numbers eg the product of 2 and 3 is 6.






[bookmark: _Toc70496300]Show values As

[image: ]2. Select how you want to display the data 
1. Select the tab Show Values As 

Most common ways of displaying data:
	Use this calculation
	To 

	No calculation
	Turn off custom calculation.

	% of Column Total
	Display all the values in each column or series as a percentage of the total for the column or series.

	% of Row Total
	Display the value in each row or category as a percentage of the total for the row or category.

	Rank smallest to largest
	Display the rank of selected values in a specific field, listing the smallest item in the field as 1, and each larger value with a higher rank value. Create a new column for Rank if you want to show the specific amounts too.

	Rank largest to smallest
	Display the rank of selected values in a specific field, listing the largest item in the field as 1, and each smaller value with a higher rank value. Create a new column for Rank if you want to show the specific amounts too.





[bookmark: _Toc70496301][image: ]Changing the sort orderMore sort options allows you to input a specific sort order
2. Select sort and the sort order you require
1.Right mouse click on a value in the data set you want to sort




[bookmark: _Toc70496302]Custom sort order
Go to File > Options > Advanced

[image: ]1. Select the option Edit Custom Lists


[image: ]2. Click on OK
3. Click on Add
4. Add your custom sort order separated by commas. 

You can also choose to import the values from a range of cells.
[bookmark: _Toc70496303]Grouping dates

In Excel 2016 forward Excel automatically groups dates by months & quarters. If you are working with an Excel version prior to that or you want to change the automatic grouping you can manually group dates.

[image: ]1. Select the Grouping you require 
2. Right mouse click on a date value 


[bookmark: _Toc70496304]Sub totals and Grand totals[image: ]1. Click Subtotals or Grand Totals to show or not show totals 
2. Click on the Pivot table


[bookmark: _Toc70496305]Open text questions
Tips
· Add a text box to your sheet to record your code
· Identify the key recurring themes
· Assign a numerical code to each theme e.g.1 = Instrument choice/availability 
· Go through all the answers assigning codes to each answer
· Add your coding to the column heading so you can refer to it
· Use Power query to split columns & unpivot data



[bookmark: _Toc70496306]Exercises
[bookmark: _Toc70496307]Multiple Choice Survey Questions
Exercise 1
[image: ]
Exercise 2
[image: ]





Exercise 3
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[bookmark: _Toc70496308]Open text question exercises
Exercise 4
[image: ]




Exercise 5
[image: ]
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Topic 2 exercise : Unpivot data - Method 1
(tabular data)
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\/Open the Power Query Editor (Data tab— Get Data - From o ””"‘T’f""d = -
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‘/Remove the Attributes column (Right mouse click— Remove)
v"Rename the Values column “Instrument”  (right mouse

clickRename)

\/Upload & Close the query (Hometab —Upload and Close)

v"Rename the results worksheet “Unpivoted data 1”
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                          Topic 2 exercise : Unpivot data  - Method 1  (tabular data)  On the Multiple Choice 1 sheet, make the data  into a table & name it “Multiplechoice1)  (Ctrl +T)  Open the Power Query Editor  (Data tab  – Get Data  - From  Table/Range button)  Unpivot the data  (Highlight the columns to unpivot using the shift key - Transform tab - Unpivot data button)  Remove the Attributes column  (Right mouse click  – Remove)  Rename the Values column “Instrument”  (Right mouse  click - Rename)  Upload & Close the query  (Home tab  – Upload and Close)  Rename the results worksheet “Unpivoted data 1”         
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Topic 3 exercise: Unpivot data (Delimited)
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Electric ey s s e
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saxaphone| 1 22128 Sy
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\/Upload & Close the Query (Home tab — Upload and Close)
v'Rename the results worksheet “Unpivoted data 2”
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Topic 4 exercise: Pivot table & Column chart

v Create a Pivot table in the Unpivot data 1 worksheet I T VT
(Click in the Table, Insert menu — Pivot table) mowomoE s W
v"Rename the worksheet “Instruments” A
v/ Add Instrument to the Rows & Prison ID to the Values 2 s Ex x m
field areas i
‘/Add d Cha rt (Click in the Pivot Table, PivotTable Analyse menu -Pivot Chart) ig
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v'Add Prison to the Columns field area 2 e
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                     Topic 4 exercise: Pivot table & Column chart  Create a Pivot table in the  Unpivot data 1  worksheet  (Click in the Table, Insert menu  – Pivot table)  Rename the worksheet “Instruments”  Add Instrument to the Rows & Prison ID to the Values  field areas  Add a chart  (Click in the Pivot Table, PivotTable Analyse menu - Pivot Chart)  Sort the results by size  (Arrow next to row column, More sort options  – Descending  – Count of Prison ID)  Add Prison to the Columns field area   Switch Instruments and Prisons between row and column  (Pivot Table Design tab  – Switch Row/Column)  Sort the Prisons column by size  (Arrow next to column header, More  sort options - Descending - Count of Prison ID)  Resize & move the chart to where you want it on the  page  (Click and drag on the corner to change the size)    
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Topic 5 exercise: Open text questions (part 1)

v'Put the data into a Table & name it “OpenTextQuestions”
\/Open the Power Query Editor (Data tab — From Table/Range button)

v'Select the columns to include in the query results: Prison ID, Prison, What do you
think would improve the sessions?, Improvement areas (Home tab - choose Columns — Select)

v'Split the data in the Improvement Area column (transform tab-Split Column button-By Number of

characters)

v"Unpivot the data (ighlight the columns to unpivot-Transform tab-Unpivot data button)

v'Remove the Attributes column (right mouse click in the column header— Remove)

v"Rename the Values column “Improvement areas” (right mouse click in the column header — Rename)
v'Upload & Close the Query (Home tab- Upload and Close)

v'Use Find & Replace to replace the number codes with text (copy the text box from the survey sheet

to make it quicker)
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Topic 6 exercise: Open ended text questions (part 2)

v'Create a Pivot table in the Unpivoted data 3 worksheet

(Click in the Table, Insert menu — Pivot table)

v'Rename the new worksheet “Improvement areas”

v'Add Imlprovement Area to the Rows & Prison ID to the
Values field areas

v"Add What do you think would Improve the sessions? To
the Rows under Improvement Areas

v'Use the + and — on the Row to show/hide rows

v Sort the Pivot chart by number of people per row (Arrow next to
row column, More sort options — Descending — Count of Prison ID)

‘/Add a pie chart (Click in the Pivot Table, PivotTable Analyse menu-Pivot
Chart)

v Format the pie chart to show percentages (Click on pie chart, Design
tab-select a format with percentages)

v"Remove the field Count of Prison ID (Rright click on the field in the
chart — Remove)

v'Hide all field buttons (Right click on a field in the chart — Select Hide All
Field buttons)

v"Rename the chart (pouble click into the Title to type in a new heading)
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