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[bookmark: _Toc71878211]Introduction to Dashboards
A Dashboard is a type of graphical user interface which provides at-a-glance, interactive views of key performance indicators relevant to a particular objective. Or more simply put, in Microsoft Excel it’s simply a collection of pivot charts on a worksheet.
Dashboard Best Practice
· Decide what you want to say to your audience and make sure that all everything on the dashboard is telling that story.
· Don’t over complicate – it’s better to have a clean, simple dashboard than one brimming with so many charts it’s impossible to take it all in.
· Keep colour schemes consistent and simple.
· Think about how your audience is going to be viewing it – on a PC/laptop or on a mobile device
· Security – Excel dashboards sit in spreadsheets full of data. Make sure you think about who is going to have access and how much data they can have access to.
· Printing - make sure it fits on one page

Questions to ask before you begin building your dashboard
· Why are you creating this dashboard? Are you trying to prove or disprove a hypothesis? Is this dashboard for a specific task, like showing status of a project, or does it need to achieve a broader goal, like measuring business performance? Understanding why you are building the dashboard will help guide the design and data.
 
· Do you need to track certain KPIs? Your dashboard should only highlight data that adds value. Make sure you understand the most important KPIs and create the dashboard around those metrics. Anything outside those main KPIs aren’t necessary.
 
· Who needs to see the dashboard? Is this for your colleagues, your management team, your board of trustees? How do these people prefer to digest information? How much time do they have to look at this dashboard? Think about who you’re making the dashboard for and keep their preferences in mind.
 
· Where will the data come from? Do you need to manually import data into your dashboard or will you use an integration or connector to automatically sync and refresh data? What other tools do you use to gather data? 
· How up to date does the dashboard need to be? Can you update your dashboard weekly or monthly, or does it always need to show real-time, updated information? Depending on what you chose, this will change the way you build your dashboard. 
 
· What format does the dashboard need to be in? Are you emailing a static dashboard or providing a link to a dynamic one? Does the dashboard need to be embedded in presentations or decks? Do you want to share read-only access or do you want to provide editing capabilities to certain people? 

Tables
[bookmark: _Toc71878212]Make your data into a table
2. Click on the Table command button 

[image: ]1. Click on the Insert tab 

Alternative shortcut: Ctrl + T
[image: ]3.  A window will open. Confirm the cells to be included in the table and that the data has headers

[bookmark: _Toc33454288][bookmark: _Toc71878213]Name the table
It is good practice to name the table as it makes life much easier later when working with formulas. Naming the formula is basically giving your data set a name which will enable you to recognise which data set you need to be working with.
[image: ]2. Rename the table. For example, “BookingData”
1. Click on the table & select the Design tab

[bookmark: _Toc33454318][bookmark: _Toc71878214]Pivot Tables
1. [bookmark: _Toc33454319][bookmark: _Toc71878215]Creating a pivot table
2. Select the table you want to base the pivot table on. Here you can see the table name “participants”. Using a table ensures you have a dynamic data source for your pivot table











3. Select New Worksheet 








1. Click on the Insert tab 
2. Click on Pivot Table



4. An empty pivot table is created





5. The columns from your table appear in the fields







6. To create a simple pivot table drag and drop the field you want to organise into the Rows box and the Name field into Values








7. The pivot table now displays how many prisoners attended the music sessions from each prison







8. As the name field is text the pivot table assumes you want to Count the number of records in the Name
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[image: ]9. Add complexity to your Pivot table. To show how many of the attendees from each prison already had musical experience, add the field Musical experience to the Columns field









1. [bookmark: _Toc33454320][bookmark: _Toc71878216]Field values
Numerical fields can be displayed in a number of ways in Pivot tables, for example you can display fields as a percentage of the grand total.
[image: ]2. Select Show Values As and then % of Grand Total








1.Highlight the fields you want to display as a percentage.










[image: ]4. Use the Decrease decimal place command button to round numbers.








3. Percentages replace the original numbers









1. [bookmark: _Toc33454321][bookmark: _Toc71878217]Sorting & Filtering a pivot table
Simple sorting and filtering work exactly the same as elsewhere in Excel.
Click next to the row or column heading for sorting and filtering options























1. [bookmark: _Toc33454324][bookmark: _Toc71878218]Refreshing data in a Pivot table
[image: ]If you make changes to the data set being used to the pivot table, you might need to refresh the chart so that the changes are immediately reflected in the chart.

1. [bookmark: _Toc33454325][bookmark: _Toc71878219]Recommended Pivot Tables
A short cut to creating pivot tables can be to use the recommended Pivot table function.

1. [bookmark: _Toc33454326][bookmark: _Toc71878220]Pivot table charts
1. Click on the pivot table and then on the PivotChart command button








2. Choose the chart type









· [image: ] (red for any less than 2) 


3. Choose the chart format














[bookmark: _Toc71878221]Working with Pivot tables

[bookmark: _Toc71878222]Changing value field settings
In pivot tables you can select different types of setting for the values portion of your Pivot table. You can:
· Give the value set a custom (display) name
· Specify how you want to summarise values 
· Specify how you want to display values
1. Right mouse click on the Value eg Sum of Client ID and select the option Value Field Settings




















[bookmark: _Toc71878223]Custom value name
Type in the name you would like to use for the value field. 

[bookmark: _Toc71878224]Summarise values by

[image: ]1. Select the tab Summarise Values By 
2. Select how you want your field summarised 




Most common calculations used to summarise data:
	Function 
	Summarizes 

	Sum
	The sum of the values adds all the values in the selected data range. This is the default function for numeric values.

	Count
	The number of values. The Count summary function works the same as the COUNTA worksheet function. Count is the default function for values other than numbers.

	Average
	The average of the values. The average is the mean average of the numbers. To calculate: Excel adds up all the numbers, then divides by how many numbers there are. In other words it is the sum divided by the count.

	Max
	The largest value.

	Min
	The smallest value.

	Product
	The product of the values. The product is the result of multiplying the numbers eg the product of 2 and 3 is 6.



[bookmark: _Toc71878225]Show values As

[image: ]3. Change the number format 
2. Select how you want to display the data 
1. Select the tab Show Values As 

Most common ways of displaying data:
	Use this calculation
	To 

	No calculation
	Turn off custom calculation.

	% of Column Total
	Display all the values in each column or series as a percentage of the total for the column or series.

	% of Row Total
	Display the value in each row or category as a percentage of the total for the row or category.

	Rank smallest to largest
	Display the rank of selected values in a specific field, listing the smallest item in the field as 1, and each larger value with a higher rank value. Create a new column for Rank if you want to show the specific amounts too.

	Rank largest to smallest
	Display the rank of selected values in a specific field, listing the largest item in the field as 1, and each smaller value with a higher rank value. Create a new column for Rank if you want to show the specific amounts too.




[bookmark: _Toc71878226][image: ]Changing the sort orderMore sort options allows you to input a specific sort order
2. Select sort and the sort order you require
1.Right mouse click on a value in the data set you want to sort




[bookmark: _Toc71878227]Custom sort order
Go to File > Options > Advanced

[image: ]1. Select the option Edit Custom Lists


[image: ]2. Click on OK
3. Click on Add
4. Add your custom sort order separated by commas. 

You can also choose to import the values from a range of cells.
[bookmark: _Toc71878228]Grouping dates
In Excel 2016 forward Excel automatically groups dates by months & quarters. If you are working with an Excel version prior to that or you want to change the automatic grouping you can manually group dates.

[image: ]1. Right mouse click on a date value 
2. Select the Grouping you require 

[bookmark: _Toc71878229]Working with Charts
[bookmark: _Toc71878230]Anatomy of a chart
[image: ]

[bookmark: _Toc71878231]Creating Pivot charts
[image: ] 1.Click on the Pivot table you want to make into a chart







2. Click on Pivot Chart




3. Choose the chart type







4. Choose the chart format








[bookmark: _Toc71878232]Chart designChange the colour palette






Select the chart style







[bookmark: _Toc71878233]Change chart typeChange the chart type








[bookmark: _Toc71878234]Chart elementsClick on the + symbol to reveal the chart elements. (De)select to add and remove chart elements







Different Chart Elements options will appear depending on the type of chart









Drill down to select more options 







[image: ]Click on the arrow next to the chart element to reveal a drop-down menu of options









[bookmark: _Toc71878235]Hide Value field button settings1. Click on a value field button in the chart






2. Select hide the selected button or hide all










[bookmark: _Toc71878236]Changing the data series
[bookmark: _Toc71878237]Making Rows/columns broader
3. Change the Gap width to increase the width of the bars





2. The Format window will open




















1. Click on the data series (in this instance the bars in the chart) to select






[bookmark: _Toc71878238]Make each data point a different colour
3. Check the Vary Colours by point option




1. Click on the data series (in this instance the columns in the chart) to select it.





2. In the format window click on the Fill & Line command button







[bookmark: _Toc71878239]Creating an Excel Dashboard
[bookmark: _Toc71878240]Preparing your Workbook
Create worksheets in your workbook as follows:
1. Data
2. Analysis 
You can create these as you begin to work on the data. Ideally create one worksheet for each pivot table.
3. Dashboard
1
2
3





[bookmark: _Toc71878241]Formatting your Dashboard
[bookmark: _Toc71878242]Add Title
Add a text box to add a title to your chart
Copy and paste charts in from other sheets, hold Alt key down when moving to snap charts to the gridlines
[bookmark: _Toc71878243]Hide Gridlines, Headers & the formula bar[image: ]On the view tab, check/uncheck
Sheet elements you wish to show/hide


[bookmark: _Toc71878244]Formulas
[bookmark: _Toc71878245]GETPIVOTDATA
Created by simply entering a = in the destination cell and then clicking on the source cell. Excel creates the formula, like the one in the example below, for you so there is no need to type it in.
GETPIVOTDATA("Count of Customer ID",Attendance!$A$3,"Status","Attended")
[bookmark: _Toc71878246]IFERROR
Wrap the IFERROR formula around formulas so that if no data or incorrect data causes an error your formula will return a value of your choosing. In the formula below we use the IFERROR to return a 0 if there is an error in the data
· =IFERROR(GETPIVOTDATA("Count of Customer ID",Attendance!$A$3,"Status","Attended"),0) 

[bookmark: _Toc71878247]Slicers
1. Click on the Insert tab


2. Click on Slicer









2. Select the column(s) you would like to use for filtering



3. Select the field you want to use as a filter
















[bookmark: _Toc71878248]Formatting a Slicer
When using a slicer it is a good idea to only include only filters for where data exists otherwise the filter will return no results.
[image: ]1. Right click on Slicer and select the option Slicer Settings. Then tick the box Hide items with no data.

[bookmark: _Toc71878249]Linking the slicer to your charts
[image: ]1. Select the Slicer
2. In the Slicer tab ribbon, click on Report Connections in the Slicer Tab

[bookmark: _Toc71878250]Refreshing the Dashboard

[image: ]Select Refresh All on the Data tab

[bookmark: _Toc71878251]Session Exercises
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T 1

Topic 2 - Exercise 1:Borough bar chart

Make the source data into a table (Insert menu — Table)

Rename the table to “Data” (Click on Table go to Table Design menu - Table name)

Insert Pivot table (Insert tab- Pivot table)

Rename Sheet tab to Boroughs

In the pivot table select: Axis=borough, values=customer ID.

In the Customer ID in values, change the value field settings, change customer ID to Count not Sum
Rename the pivot table to “Borough” (PivotTable-Analyze tab — PivotTable Name field)
Insert a Pivot Chart (PivotTable-Analyze tab — Pivot chart command button)

Change the sort order on the pivot table to Z-A

Resize chart

Hide All field buttons (Right mouse click on one & select Hide all field values on the chart)
Remove Title (Click on it and press delete on the keyboard)

Add data labels (Click on the + to access the chart elements & deselect)

Remove gridlines (Chart Elements - deselect)

Remove Legend (Chart Elements - deselect)

Remove horizontal axis (Chart Elements — Axes — deselect Primary horizontal)

Reduce gap width so that the rows are fatter (Select data series -Format Menu — Series Options- Gap width)

Barnet

Brent
Bromley
Camden

City of London
Croydon
Ealing

Enfield
Hackney

Hammersmith &...

Harrow
Havering
Highbury and islington
Hounslow
Islington
Kingston
Lambeth
Lewisham
Merton
Newham

Not Applicable
Richmond
Southwark
Sutton

Tower Hamlets
Waltham Forest
Wandsworth
Westminster

I- mge
i ~ ~
IS
«n o o
N o ™
—
=

_I I.I-I .I-
-
~ oo~
w w
o
-
< <
o
B
-
- &

I-
oo




image57.png
Reach across London

&

Exercise 2: Reach

v Go to borough sheet

v Enter Total London boroughs = 33

v Add Boroughs attending. Use formula = CountA(A4:A31)

v Add Boroughs not attending = London boroughs - boroughs attending
v Add Reach Percentage = 28/33 and change field type to %

v Select boroughs attending & not attending + numbers and add a donut chart

= Boroughs attending = Boroughs not attending

v Select the data series to decrease the donut hole size (Select data series -Format
Menu — Series Options- Donut hole size)

v Add a box into the middle, white fill & no outline, and then put % field in
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Exercise 3: New to Superhighways pie chart

v Insert Pivot Table

v Add New to Superhighways to Row & Customer number to Values
v Change Customer number from Sum to Count

v Add Pivot chart, type Pie (Chart design tab- Change chart type) New to Superhighways?
v Hide the value field buttons on the chart

v Change chart title to "New to Superhighways?"

v Change data labels (+ Chart Elements - Data labels - More options...Label
options)

v Change label from Value to Percentage & add category
v"Remove legend (+Chart elements - uncheck Legend)

v Change label text colour to white, make it bold & increase point (Home
tab)

v"Rename Tab "New to Superhighways”
v Change the Theme (Page Layout menu)
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Exercise Topic 4: Organisation Type

v Insert Pivot chart & Table
v Add Organisation Type to Row/Axis & Customer number to Values

. T f O isati
v"In Values, change Customer number from Sum to Count (Click on arrow next ype of Organisation

to the chart value to select a different field type) 101
v Use Row Labels filter to remove blanks

v Select data series, click on Fill & Line button, check Vary colours by point

41

v"Remove Legend, Gridlines & Vertical Axis (+Chart elements)
v Hide All field buttons (Right mouse click on one) I o
v Increase width of columns (Select data series & decrease gap width) Frontine infrastructure Funder

v Change title to “Type of Organisation”
v"Rename Tab to "Type of Organisation”
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Exercise 5: Attendance numbers

v Insert Pivot table (not a chart)

J — —
Rows=status , values=customer ID x 2, change customer ID to Count Attendance

v Summarise values by: Change Status 1 value to Count
v Change Customer ID 2 value to % 81
74%

v Rename Pivot “Attendance”

v"Rename sheet “Attendance”
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Exercise 6: Training Location

v Insert pivot table & chart

v Rows/Axis - Years, Values = Count of Customer ID, Column = Training
Location

TRAINING LOCATION

v Change chart type to Stacked column (Pivot Design tab)
v Change chart design style (Pivot design tab)

® Tower Hamlets

v Hide All field buttons (Select data series & right mouse click) wouthark
v"Remove Gridlines & Primary vertical axis (+Chart Elements) B :,L,:tth
v Add data labels (+ Chart Elements) 2 croydon
v Change title to "Training Locations" = j

v"Rename pivot & sheet to "Training Location”
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Exercise 7: Putting it all together 1

v Create & name a tab for the dashboard

v Copy & paste all the charts into the dashboard (Keystrokes = ctrl + ¢
& ctrl+v)

v Add a slicer (Insert menu — Slicer)

v" Connect the slicer to the pivot tables (Slicer menu — report
connections)

v Remove options with no data from the slicer(Slicer menu — Slicer
settings)
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Exercise 8: Putting it all together 2

v Use the Get pivot data formula to add in Attendance & No show
numbers (Add = to the destination cell and then go to the source
cell and click on enter)

v" Amend Get pivot data formula function to allow for 0 values
without returning an error:

v =|[FERROR(GETPIVOTDATA("Count of Customer
ID",Attendance!SAS3,"Status","Attended"),0)

v"Remove outlines from the shapes (use the shift key to select
multiple & right mouse click)

v"Remove gridlines




image64.jpeg
2‘ superhighways

for community b




image65.png
\
\ ‘\“I’,',/
2

3

70
N\




